Network Tools

SULAIMAN

(11615011)

 

LAPORAN 1

NETWORK TOOLS

 

A.TUJUAN PEMBELAJARAN:

1.    Mahasiswa mampu menggunakan tools jaringan yang ada.

2.    Mahasiswa memahami perintah – perintah dasar konfigurasi jaringan

3.    Mahasiswa memahami konsep layering

 

B.DASAR TEORI

Dalam melakukan tugas-tugas administrasi sistem, administrator sistem mau tidak mau akan banyak berhubungan dengan tools – tools pendukung. Tanpa bantuan tool ini pekerjaan administrasi akan sulit dijalankan.

 

 

1.      Network Management :

·         Etherman

Tool yang berbasis GUI yang menampilkan representasi dari komunikasi – komunikasi ethernet secara real time

·         Tcp wrapper

Berguna untuk mengontrol siapa saja yang mengakses sistem. Dapat memproteksi usaha pelanggaran terhadap sistem

·         Xmotd

Dipakai menuliskan atau menampilkan Message of the day, untuk setiap user yang login

·         Samba

Memungkinkan  melakukan sharing file antar so

·         Swatch

program untuk memonitor log

·         dig

query server domain

·         host

memperoleh informasi nama domain

·         nslookup

·         tcpdump

mengcapture packet

·         traceroute

melakukan trace terhadap rute paket IP dari sistem ke sistem tujuan

·         sniffit

tools memberikan informasi detail ttg semua traffic jaringan

·         ssl

·         netstat

 

Ada beberapa command pada linux yang dipakai untuk melakukan  konfigurasi dan troubleshooting jaringan :

Layer phisik

1.      lspci

Merupakan tools yang berada pada layer 1, dipakai untuk mengecek apakah interface jaringannya sudah terpasang atau belum. Apabila ditemukan Network controller atau Ethernel controller, artinya perangkat jaringan sudah siap digunakan.

2.      mii-tool

Untuk melihat apakah linknya sudah ada atau belum

3.      dmesg | grep eth

Untuk mengecek ethernet card ada apa belum

 

Layer datalink

1.      arp

Merupakan tools yang dipakai untuk melihat alamat NIC dari komputer yang terkoneksi secara langsung dengan kita.

 

Layer IP

1.      ifconfig

Command yang dipakai untuk melihat interface dan alamat yang diberikan ke interface tersebut

2.      route

Memeriksa tabel routing, menambah dan menghapus tabel routing

3.      ping

Memeriksa koneksi dengan protokol ICMP

4.      traceroute

Memeriksa tahapan koneksi

5.      mtr

Command gabungan ping dan traceroute

6.      netconfig

Command untuk konfigurasi ip secara permanen

 

Layer Transport

1.      Netstat

Untuk mengetahui port berapa saja yang terbuka untuk koneksi pada PC

 

 

TUGAS PENDAHULUAN

 

Jelaskan cara penggunaan command dibawah ini beserta option yang digunakan dan artinya

1. lspci

2. mii-tool

3. arp

4. ifconfig

5. route

6. ping

7. traceroute

8. mtr

9. netstat

10. netconfig

 

C.PERCOBAAN

 

1. Jalankan perintah “dmesg | grep eth”, catat dan analisa hasilnya. Jika tidak ada keluaran konfirmasikan ke dosen/asisten praktikum.

2. Lepaskan kabel jaringan, lakukan perintah mii-tool

3. Pasangkan lagi kabel jaringan dan lakukan perintah mii-tool

4. Catat hasil dari perintah “lspci” sebelum dan sesudah melepas kabel

5. jalankan perintah ”arp –a” dan catat hasilnya , buka beberap terminal baru lagi dan jalankan perintah ”ping no_ip_tujuan” ke beberapa komputer sebelah (tanya nomor IP tersebut ke teman). Pada terminal pertama lakukan perintah arp –a sekali lagi . Catat hasilnya dan bandingkan dengan hasil arp yang pertama, analisa hasilnya

6. Jalankan perintah ”ifconfig”, catat hasilnya.

7. Jalankan perintah route –n, catat hasilnya.

8. Pastikan anda terhubung ke internet, mintalah tolong ke dosen/asisten praktikum jika belum bisa terhubung ke internet.

9. Jalankan perintah ”traceroute” dan ”mtr” ke :

1.  202.154.187.3

2.  http://www.eepis-its.edu

3.  http://www.yahoo.com

Catat hasilnya

10. Buka halaman http://www.eepis-its.edu dengan web browser, kemudian sebelum koneksi selesai, buka terminal dan catat hasil koneksi dengan perintah “netstat -natu”

11. Jalankan perintah netconfig, isikan data berikut ip: 192.168.1.xx (xx mulai 1-254, koordinasikan dengan teman anda agar tidak ada yang memakai nomor yang anda ambil. Isikan juga netmask :255.255.255.0 yang lain dikosongi terlebih dahulu dan tekan tombol OK.

12. Selanjutnya jalankan perintah ifconfig catat hasilnya. Bandingkan dengan ketika anda menjalankan perintah ifconfig pada nomor 6, apa hasilnya ?

13. Jalankan perintah netstat, catat hasilnya

 

D.HASIL PERCOBAAN

 

1. Hasil perintah “dmesg | grep eth”

2. lepaskan kabel jaringan dan jalankan perintah mii-tool

3. Pasangkan kembali kabel jaringan dan jalankan perintah “mii-tool

4. Jalankan perintah “lpsci” dan catat hasilnya sebelum dan sesudah melepas kabel.

5. Jalankan perintah “arp-a” dan catat hasilnya lalu buka terminal baru lagi dan jalankan perintah “ping no_ip_tujuan” ke beberapa komputer sebelah lalu pada terminal pertama lakukan perintah arp-a sekali lagi.

6.  Jalankan perintah “if-config”

7. jalankan perintah “route-n”

 

E.PERTANYAAN

 

1. Berikan kesimpulan hasil praktikum yang anda lakukan untuk masing-masing perintah !

2. Berdasarkan hasil catatan praktikum anda,, perintah lspci apa maksud keluaran itu ?

3. berdasarkan catatan praktikum anda khususnya perintah mii-tool apa maksud keluaran itu ?

4. berdasarkan catatan praktikum anda khususnya perintah arp-a apa maksud hasil keluaran itu ?

5. berdasarkan catatan praktikum anda khususnya perintah ifconfig apa maksud hasil keluaran itu ?

6. berdasarkan catatan praktikum anda khususnya perintah perintah route-n apa maksud hasil keluaran itu ?

 

F.JAWABAN PERTANYAAN

 

1. Berdasarkan hasil praktikum yang telah dilakukan maka dapat disimpulkan bahwa setiap perintah memiliki fungsi masing-masing. koneksi jaringan menentukan hasil dari perintah tersebut, ketika melakukan perintah yang terhubung dengan jaringan dan yang tidak terhubung maka hasil yang didapat akan berbeda.

 

2. perintah lspci untuk mengecek apakah interface jaringannya sudah terpasang atau belum. apabila ditemukan Network Controller atau Ethernet Controller, artinya perangkat jaringan sudah siap digunakan.

 

3. perintah mi-tool yaitu untuk melihat status dari interface network dan untuk melihat apakah linknya sudah ada atau belum.

 

4. perintah arp-a untuk melihat alamat NIC dari kommputer yang terkoneksi secara langsung dengan kita.

 

5. perintah ifconfig untuk melihat interface dan alamat yang diberikan ke interface tersebut.

 

6. perintah route -n untuk mengatur routing static yang menjelaskan host atau network melalui interface setelah dikonfigurasi dengan ifconfig.

Telnet Server dan File Transfer Protocol

SULAIMAN

(11615011)

 

LAPORAN II

ADMINISTRASI JARINGAN

 

Judul Percobaan : Telnet Server dan File Transfer Protocol

Dasar Teori :

FTP menggunakan protokol transport TCP untuk mengirimkan file. TCP dipakai sebagai protokol transport karena protokol ini memberikan garansi pengiriman dengan FTP yang dapat memungkinkan user mengakses file dan direktory secara interaktif, diantaranya :
· Melihat daftar file pada direktory remote dan lokal.
· Menganti nama dan menghapus file
· Transfer file dari host remote ke lokal (download)
· Transfer file dari host lokal ke remote (upload)

Pada gambar dibawah menunjukkan mekanisme transfer file dari host lokal ke remote, proses transfer file seperti ditunjukkan dengan tanda panah pada gambar tersebut. Tahapan FTP dimulai dari client memasuki jaringan TCP/IP, komputer remote yang akan dituju disebut host FTP, dan host FTP ini harus memiliki software FTP server yang telah diinstall agar dapat berinteraksi dengan sistem file pada host. Untuk memulai melakukan FTP, maka berikan perintah seperti berikut :

%ftp [hostname]

tanda % adalah prompt default pada OS Unix, hostname merupakan nama secara simbolik atau IP address dari host yang akan dituju. Bila sudah dapat tersambung maka akan ditanyakan nama user dan password, isian nama user dan password sesuai dengan account yang diberikan seperti yang digunakan bila user akan menggunakan server tersebut, tetapi pada FTP server yang umum, untuk nama user dapat digunakan ftp atau anonymous dengan menggunakan password yaitu alamat e-mail, akan tetapi memiliki hak akses yang terbatas sesuai yang ditetapkan administrator FTP server.

Tugas Pendahuluan :

1. Apa perbedaan fungsi telnet dan ftp ?
2. Klasifikasikan jenis ftp server berdasarkan tipe usernya!
3. Pada Linux Redhat versi 8.0 keatas, program ftp server telah menggunakan vsftpd, setelah sebelumnya digunakan wu-ftpd. Sebutkan beberapa keunggulan dari program vsftpd dibandingkan dengan wu-ftpd.

Jawab :

1. Fungsi Telnet, antara lain sebagai Program yang memungkinkan akses terminal secara remote lewat suatu jaringan. Fungsi FTP untuk melakukan operasi file dasar pada host remote dan untuk mentransfer file antar host dan untuk melakukan pengunduhan (download) dan penggugahan (upload) berkas-berkas komputer antara klien FTP dan server FTP.

2. a)    Anonymous FTP Server atau dapat juga disebut Public FTP Server. Server komputer ini dapat diakses dan terbuka bagi semua pemakai internet. File-file dalam server ini dapat di-download secara gratis. Untuk menggunakan Anonymous FTP ini pennguna memasukkan login dengan username Anonymous dan password yang dipakai berupa alamat e-mail atau dapat pula menggunakan username guest tanpa password, hal ini tergantung dari server FTP yang dituju.

b)    Private FTP Server, Server komputer ini hanya bisa diakses dan dipergunakan oleh usertertentu yang terdaftar secara resmi. Server ini biasanya berisi data dan informasi pribadi yang khusus digunakan untuk pemakai tertentu atau perusahaan tertentu. Pemakai khusus ini biasanya mempunyai username dan password untuk dapat terhubung dengan server jenis ini.

3. – vsftpd jauh lebih aman dan cepat dibandingkan dengan wu-ftpd.
– vsftpd memiliki fitur virtual IP configuration, virtual users, powerful peruser configurability dan bandwidth throttling.

Tuliskan kembali langkah-langkah praktikum dan setting file konfigurasi
1. Login sebagai root dengan mengetikkan perintah : sudo su
2. Menginstall program vsftpd dan telnetd :
# apt-get install vsftpd
# apt-get install telnetd

 
3. Jalankan perintah # ifconfig :

5. Catatlah berapa nomer port yang digunakan oleh telnet dan ftp. File /etc/services menyimpan file nomor port dan service daemon.
# cat /etc/services | grep ftp

6. Melakukan perintah dibawah ini :
# vi /etc/vsftpd.conf
7. Menghapus rule firewall dengan perinah :
# iptables -F

8. Uji coba localhost dengan perintah dibawah ini :
# telnet localhost
# ftp localhost

Daftar Pertanyaan
Apa beda telnet dan ftp ?
Protokol TELNET dipakai untuk menyamai seperti terminal yang terkoneksi untukhost secara remote (berjauhan). Prinsip kerjanya menggunakan TCP sebagai protokol transport untuk mengirimkan informasi dari keyboard pada user menujuremote-host serta menampilkan informasi dari remote-host ke workstation pada user.
FTP menggunakan protokol transport TCP untuk mengirimkan file. TCP dipakai sebagai protokol transport karena protokol ini memberikan garansi pengiriman dengan FTP yang dapat memungkinkan user mengakses file dan directory secara interaktif, diantaranya:

  • Melihat daftar file pada direktory remote dan lokal.
  • Menganti nama dan menghapus file
  • Transfer file dari host remote ke lokal (download)
  • Transfer file dari host lokal ke remote (upload)

Sebutkan software ftp client yang anda kenal (min 3) ?

Macam – macam FTP Client :

– FTP Client Under Windows:

Cute FTP

WS_FTP

Get Right

Go!zilla

Coffe Cup

Kazza

– FTP Client Under UNIX :

telnet

axyFTP

wget

caitoo

cftp

curl

downloader

moxftp

ncftp

Apa beda ftp biasa dan anonimous ftp ?
FTP user artinya ftp yang dapat di akses dan memiliki permisi hanya di batasi hanya untuk user tertentu. Karena ftp user disertakan suatu autentifikasi bila kita akan mengakses ke dalam nya. Sedangkan FTP anonymous artinya, FTP yang disediakan secara anonymous/ tanpa nama, dengan kata lain FTP tersebut dapat di akses oleh siapapun dan biasanya tanpa password, ataupun bila di minta password,. Biasanya server meminta alamat email kita sebagai password nya untuk ferivikasi.

SSH dan SFTP

SULAIMAN

(11615011)

 

LAPORAN III

ADMINISTRASI JARINGAN

 

Judul Percobaan : SSH dan SFTP

 

Dasar Teori :

Secure Shell, Secure Copy & Secure FTP

Secure Shell (ssh) adalah suatu protokol yang memfasilitasi sistem komunikasi yang aman diantara dua sistem yang menggunakan arsitektur client/server, serta memungkinkan seorang user untuk login ke server secara remote. Berbeda dengan telnet dan ftp yang menggunakan plain text, SSH meng-enkripsi data selama proses komunikasi sehingga menyulitkan penyusup/intruder yang mencoba mendapatkan password yang tidak dienkripsi. Fungsi utama aplikasi ini adalah untuk mengakses mesin secara remote. Bentuk akses remote yang bisa diperoleh adalah akses pada mode teks maupun mode grafis/X apabila konfigurasinya mengijinkan.

SSH dirancang untuk menggantikan service-service di sistem unix/linux yang menggunakan sistem plain-text seperti telnet, ftp, rlogin, rsh, rcp, dll). Untuk menggantikan fungsi ftp dapat digunakan sftp (secure ftp), sedangkan untuk menggantikan rcp (remote copy) dapat digunakan scp (secure copy).

Dengan SSH, semua percakapan antara server dan klien di-enkripsi. Artinya, apabila percakapan tersebut disadap, penyadap tidak mungkin memahami isinya. Bayangkan seandainya Anda sedang melakukan maintenance server dari jauh, tentunya dengan account yang punya hak khusus, tanpa setahu Anda, account dan password tersebut disadap orang lain, kemudian server Anda dirusak setelahnya.

Implementasi SSH yang banyak dipakai saat ini adalah OpenSSH, aplikasi ini telah dimasukkan kedalam berbagai macam distribusi linux.  Redhat Linux versi 9 sudah menyediakan program tersebut dalam format RPM.

Fitur-fitur SSH

Protokol SSH menyediakan layanan sbb.:

·         Pada saat awal terjadinya koneksi, client melakukan pengecekan apakah host yang dihubungi sudah terdaftar pada client atau tidak.

·         Client mengirimkan proses autentifikasi ke server menggunakan teknik enkripsi 128 bit.

·         Semua data yang dikirimkan dan diterima menggunakan teknik enkripsi 128 bit sehingga sangat sulit dibaca tanpa mengetahui kode enkripsinya.

·         Client dapat memforward aplikasi Xwindows / X11 ke server, layanan ini dibuat .

 

Secure Shell, Secure Copy & Secure FTP

Secure Shell (ssh) adalah suatu protokol yang memfasilitasi sistem komunikasi yang aman diantara dua sistem yang menggunakan arsitektur client/server, serta memungkinkan seorang user untuk login ke server secara remote. Berbeda dengan telnet dan ftp yang menggunakan plain text, SSH meng-enkripsi data selama proses komunikasi sehingga menyulitkan penyusup/intruder yang mencoba mendapatkan password yang tidak dienkripsi. Fungsi utama aplikasi ini adalah untuk mengakses mesin secara remote. Bentuk akses remote yang bisa diperoleh adalah akses pada mode teks maupun mode grafis/X apabila konfigurasinya mengijinkan.

SSH dirancang untuk menggantikan service-service di sistem unix/linux yang menggunakan sistem plain-text seperti telnet, ftp, rlogin, rsh, rcp, dll). Untuk menggantikan fungsi ftp dapat digunakan sftp (secure ftp), sedangkan untuk menggantikan rcp (remote copy) dapat digunakan scp (secure copy).

Dengan SSH, semua percakapan antara server dan klien di-enkripsi. Artinya, apabila percakapan tersebut disadap, penyadap tidak mungkin memahami isinya. Bayangkan seandainya Anda sedang melakukan maintenance server dari jauh, tentunya dengan account yang punya hak khusus, tanpa setahu Anda, account dan password tersebut disadap orang lain, kemudian server Anda dirusak setelahnya.

Implementasi SSH yang banyak dipakai saat ini adalah OpenSSH, aplikasi ini telah dimasukkan kedalam berbagai macam distribusi linux.  Redhat Linux versi 9 sudah menyediakan program tersebut dalam format RPM.

Fitur-fitur SSH

Protokol SSH menyediakan layanan sbb.:

·         Pada saat awal terjadinya koneksi, client melakukan pengecekan apakah host yang dihubungi sudah terdaftar pada client atau tidak.

·         Client mengirimkan proses autentifikasi ke server menggunakan teknik enkripsi 128 bit.

·         Semua data yang dikirimkan dan diterima menggunakan teknik enkripsi 128 bit sehingga sangat sulit dibaca tanpa mengetahui kode enkripsinya.

·         Client dapat memforward aplikasi Xwindows / X11 ke server, layanan ini dibuat .

 

Tugas Pendahuluan

 

  1. Apa kelebihan secure shell dibanding perintah telnet, ftp dan perintah remote lainnya.
  2. Sistem enkripsi apa yang digunakan oleh program ssh pada Redhat Linux 9 dan debian.
  3. Jelaskan bagaimana program ssh bekerja pada sistem jaringan client/server.

 

Jawab :

1. Telnet  :

•         Unsecure

•         Authentifikasi

•         Proses cepat

•         Port 23

SSH :

•         Secure

•         Authentifikasi

•         Proses lama

•         Port 22

2. Sistem enkripsi dengan 128 bit

 

3.

 

•      Perintah REXEC digunakan untuk menjelaskan user ID, password, host address dan proses untuk memulai suatu proses pada remote host. Disisi lain, RSH tidak membutuhkan pengiriman user name dan password tetapi menggunakan host access file server maupun client tersambung dengan jaringan TCP/IP

•         REXEC menggunakan TCP port 512 dan 514

 


Hasil Percobaan :

1. Login ke sistem Linux sebagai root

nb1@nb1-laptop:~$ sudo su

 

2. Untuk menjalankan ssh kita harus menginstalnya terlebih dahulu dengan mengetik perintah #apt-get install ssh server :

root@nb1-laptop:/home/nb1# apt-get install openssh-server
Reading package lists… Done
Building dependency tree
Reading state information… Done
openssh-server is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 427 not upgraded.
3. Mengaktifkan service ssh server.Untuk menjalankan service ssh gunakan perintah service ssh start  :

root@nb1-laptop:/home/nb1# service ssh start
start: Job is already running: ssh

Untuk menstopkan service ssh gunakan perintah service ssh stop :root@nb1-laptop:/home/nb1# service ssh stopssh stop/waiting

4. Protokol apa yang digunakan oleh program ssh ?

root@nb1-laptop:/home/nb1# netstat -a | grep ssh
unix  2      [ ACC ]     STREAM     LISTENING     7821     /tmp/ssh-hRVKLH1326/agent.1326
unix  2      [ ACC ]     STREAM     LISTENING     8217     /tmp/keyring-8LISkg/ssh

 

5. Catatlah berapa nomer port yang digunakan oleh service ssh

root@nb1-laptop:/home/nb1# cat /etc/services | grep ssh
ssh         22/tcp                        # SSH Remote Login Protocol
ssh         22/udp

 

6. Uji coba dari localhost

root@nb1-laptop:/home/nb1# ssh localhost
ssh: connect to host localhost port 22: Connection refused
root@nb1-laptop:/home/nb1# ssh localhost -p24893
The authenticity of host ‘[localhost]:24893 ([::1]:24893)’ can’t be established.
RSA key fingerprint is 4b:93:a4:d3:30:32:84:24:cc:66:7d:5d:76:47:55:e2.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added ‘[localhost]:24893’ (RSA) to the list of known hosts.
root@localhost’s password:
Permission denied, please try again.
root@localhost’s password:
Permission denied, please try again.
root@localhost’s password:
Linux nb1-laptop 2.6.32-24-generic #39-Ubuntu SMP Wed Jul 28 06:07:29 UTC 2010 i686 GNU/Linux
Ubuntu 10.04.1 LTS

Welcome to Ubuntu!
* Documentation:  https://help.ubuntu.com/

New release ‘precise’ available.
Run ‘do-release-upgrade’ to upgrade to it.

The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.

Daftar Pertanyaan : 

1.      Berikan kesimpulan praktikum yang anda lakukan.
Bahwa dengan menggunakan service ssh data yang kita kirim lebih aman dibandingkan menggunakan service ftp, karna pada ssh selama pada proses komunikasi data terenkripsi sehingga menyulitkan bagi penyusup untuk untuk mendapatkan password.
2.      Jelaskan perbedaan rlogin, rexec, rsh,rcp, ftp, telnet dengan ssh, sftp.
Telnet :
– Kurang aman
– mengirimkan data dalam teks biasa
– tidak menggunakan otentikasi apapun
– menggunakan bandwidth lebih kecil
– sudah mulai tidak digunakan lagi
– Dapat mengendalikan komputer secara jarak jauh
– user interface yang ramah, yaitu mengendalikan komputer jarak jauh seolah-olah mengendalikan komputer sendiri
– telnet biasanya menggunakan port 23

SSH :
– lebih aman
– mengenkripsi data
– menggunakan kunci publik untuk otentikasi
– menggunakan bandwidth sedikit lebih besar
– banyak digunakan karena lebih aman
– menggunakan klien-server model
– mendukung forwarding dan tunneling TCP
– ssh menggunakan port 22

Remote EXEcution Command Daemon (REXECD) adalah merupakan server yangmemperbolehkan menjalankan suatu perintah yang dikirimkan oleh suatu host melalui jaringan TCP/IP, client menggunakan aplikasi REXEC atau menggunakan Remote ShellProtocol (RSH) untuk mentransfer suatu kegiatan dari host satu ke host yang lainnya.

 

Alat remote salinan (RCP) adalah alat standar UNIX dan alat Microsoft Windows 2000. Anda dapat menggunakan alat ini untuk mentransfer file dan secara rekursif mentransfer seluruh direktori antara dua komputer.

 

SFTP :

– FTP dan FTPS (Secure FTP)

– SFTP melalui SSH
– Graphical User Interface (GUI) yang modern
– File/Folder Synchronization
– Multilingual (lebih dari 20 bahasa)
– Preview thumnail
– Perbandingan secara visual
– IPv6
– On-the-fly Compression (MODE Z)
– UTF-8 Support
– Drag & Drop
– Multiple Connections / koneksi ganda
– Auto reconnect dan resume jika terjadi broken transfers
– Transfer Integrity
– FXP (Server-To-Server Transfer) support
– Edit file secara remote
– Mencari file dan folder yang ada di server
– Enhanced NAT/UPnP Support
– Transfer Queue
– International Domain Names (IDN)
– Proxy / Firewall support
– Backup Tool
– URL Watcher
– Cache Remote Directories
– FTP command line
– Custom Commands
– CHMOD (Properties)

 

Routing (Dynamic Routing)

LAPORAN IX
Oleh: Sulaiman

Dinamic Routing

Dynamic Routing Protocol adalah Routing protokol yang memungkinkan network admin untuk mensetup jaringan tanpa harus mengupdate konten dari routing table secara manual bila terjadi perubahan. Berbeda dengan static routing yang mengharuskan admin untuk merubah route atau memasukkan command secara manual di router tiap kali terjadi perubahan jalur. Dynamic routing protocol mengkalkulasi metic yang terdapat pada satu atau lebih jalur secara automatis dengan algoritma yang dimilikinya

Static Routing
Rute Statik adalah rute atau jalur spesifik yang ditentukan oleh user untuk meneruskan paket dari sumber ke tujuan. Rute ini ditentukan oleh administrator untuk mengontrol perilaku routing dari IP “internetwork”.
Pentingnya Rute Statik
Rute Statik menjadi sangat penting jika software IOC Cisco tidak bisa membentuk sebuah rute ke tujuan tertentu. Rute Statik juga sangat berguna untuk membuat “gateway” untuk semua paket yang tidak bisa di”routing”.(default route).
“Stub Network”
Rute Statik, umumnya digunakan untuk jalur/path dari jaringan ke sebuah “stub network” (jaringan yang dibelakangnya tidak ada jaringan lain).
staticroute1.gif
Sebuah “stub network’ (kadang di sebut “leaf node”) adalah jaringan yang hanya dapat diakses melalui satu rute. Seringkali, rute statik digunakan sebagai jalan satu-satunya untuk keluar masuk jaringan Stub.

Direcly Routing

Gambar Topologi

Ok, First buat jaringan di atas dengan packet tracer
Next, liat warna pada port router. warna merah ?? itu artinya pro tsb shutdown(koid). trus ?? ya lo nyalain dong… caranya ?? nih gua kasih commandnya.

Pada R1
R1>enable
R1#configure terminal
R1(config)#interface FastEthernet 0/0
R1(config-if)#no shutdown
R1(config-if)#interface Serial 0/0/0
R1(config-if)#no shutdown
R1(config-if)#endUlangin cara di atas pada R2

Next, kita cek koneksi.
PC1 pasti bisa ping ke R1
PC2 pasti bisa ping ke R2
Nah kalo dari PC1 ping ke PC2 mau nggak ??
ok kita tes aja…

Looks like it’s failed….
Kesimpulannya metode Directly Routing hanya bisa di berfungsi jika jaringan yang digunakan sama (satu).
Dynamic Routing

Gambar Topologi

First, Buat Jaringan berdasarkan topologi di atas
Next, Configurasi RIP pada R3 dan R4

~Setting RIP R3
R2>enable
R2#configure terminal
R2(config)#router RIP
R2(config-router)#network 192.168.2.0
R2(config-router)#network 192.168.3.0
R2(config-router)#network 192.168.7.0
R2(config-router)#end

~Setting RIP R4
R4>enable
R4#configure terminal
R4(config)#router RIP
R4(config-router)#network 192.168.5.0
R4(config-router)#network 192.168.6.0
R4(config-router)#network 192.168.7.0
R4(config-router)#end

Agar R2 bisa mencapai jaringan R1 maka di perlukan adanya Static Route

~Setting Static Route pada R2
R2>enable
R2#configure terminal
R2(config)#ip route 192.168.1.0 255.255.255.0 FastEthernet 0/0
R2(config)#end

Cek ping dari R3 ke PC1
Static Routing

Gambar Topologi

Pertama, Setting Static Route pada R3

R3>enable
R3#configure terminal
R3(config)#ip route 192.168.1.0 255.255.255.0 192.168.3.1
R3(config)#end

test ping dari R3 ke PC1

gagal ya, itu karena tidak ada route pada R1 untuk sampai ke R3
untuk itu kita konfigurasi lagi R1 agar bisa sampai ke R3

R1>enable
R1#configure terminal
R1(config)#ip route 192.168.3.0 255.255.255.0 FastEthernet 0/1
R1(config)#end

cek ping lagi dari R3 ke PC1

masih gagal juga😦 , ternyata masih tidak ada route pada R2 untuk sampai ke jaringan R1 jadi setting lagi R2nya.

R2>enable
R2#configure terminal
R2(config)#ip route 192.168.3.0 255.255.255.0 FastEthernet 0/0
R2(config)#end

cek sekali lagi, ping R3 ke PC1

kali ini berhasil kan.
itu karena jalur route dari R3 ke PC1 telah di atur menjadi Static routing.

RAPID SPANNING TREE PROTOCOL (RSTP)

LAPORAN VIII
Oleh: Sulaiman

Tujuan :
– Agar mahasiswa mengetahui konsep Spanning Tree Protocol
– Agar mahasiswa memahami perbedaan antar STP dan RSTP

Dasar Teori
Pengertian RSTP
Rapid spanning tree protocol (RSTP) – pertama kali diperkenalkan pada tahun 1982 sebagai pembaharuan dari STP(standar 802.1D). Menyediakan konvergensi stanning-tree yang lebih cepat ketika ada perubahan topologi. protokol yang memungkinkan sebuah jaringan untuk berfungsi baik dengan loops atau dalam topologi.

Perbedaan antara STP dan RSTP adalah pada kondisi yang ada, jika pada STP ada 5 kondisi dan RSTP hanya ada 2 kondisi.
STP (802.1D) RSTP (802.1W) Time(s)
disable discard –
blocking discard –
listening discard 15
learning learning 15
forwarding forwarding –
Tabel 1 Perbandingan STP dan RSTP

Jembatan port RSTP :
– Root – Sebuah port forwarding yang port terbaik dari Nonroot-jembatan untuk Rootbridge.

– Ditunjuk – Sebuah port forwarding untuk setiap segmen LAN.

– Alternatif – Jalur alternatif ke jembatan akar. Jalur ini berbeda dengan menggunakan port root.

– Backup – backup A redundant path / ke segmen mana port lain jembatan sudah menghubungkan.

– Cacat – Tidak sepenuhnya bagian dari STP, seorang administrator jaringan secara manual dapat menonaktifkan port. RSTP adalah penyempurnaan dari saham STP dan karena itu sebagian besar karakteristik dasar operasi.

– Deteksi kegagalan root menukar dilakukan dalam 3 halo kali, yang 6 detik jika default halo kali belum diubah.

– Port dapat dikonfigurasi sebagai pelabuhan tepi jika mereka terpasang ke LAN yang tidak memiliki jembatan lain terlampir. Tepi ini port transisi langsung ke negara forwarding. RSTP masih terus memantau port untuk BPDUs dalam kasus jembatan tersambung. RSTP juga dapat dikonfigurasi untuk secara otomatis mendeteksi port tepi. Segera setelah jembatan mendeteksi BPDU datang ke tepi port, port menjadi port non-tepi.

Tidak seperti di STP, RSTP akan merespon BPDUs dikirim dari arah jembatan akar. Sebuah jembatan RSTP akan “mengusulkan” informasi pohon rentang untuk pelabuhan yang ditunjuk. Jika ada jembatan RSTP menerima informasi ini dan menentukan ini adalah informasi akar unggul, itu set semua port lain untuk membuang. Jembatan dapat mengirimkan sebuah “kesepakatan” untuk jembatan pertama mengkonfirmasikan informasi pohon superior spanning. Jembatan pertama, setelah menerima perjanjian ini, tahu bisa cepat transisi bahwa port ke keadaan forwarding melewati mendengarkan tradisional / transisi negara belajar. Hal ini pada dasarnya menciptakan efek mengalir jauh dari jembatan akar di mana setiap jembatan yang ditunjuk mengusulkan untuk tetangga untuk menentukan apakah itu bisa membuat transisi yang cepat. Ini adalah salah satu elemen utama yang memungkinkan RSTP untuk mencapai konvergensi kali lebih cepat dari STP.

Seperti dijelaskan dalam rincian peran pelabuhan di atas, RSTP mempertahankan cadangan rincian tentang status pembuangan port. Hal ini untuk menghindari timeout jika port forwarding saat ini adalah untuk gagal atau BPDUs tidak diterima pada port akar dalam interval tertentu.

Alat & Bahan
Software Cisco Packet Tracer 5.3

Praktikum
Dalam praktikum kali ini kita akan membuat simulasi jaringan STP sesuai dengan gambar skema topologi dibawah ini

Langkah-langkah praktikum :
– Buka aplikasi Cisco Packet Tracer
– Ambil 3 buah PC dari select device box pada bagian end devices lalu tempatkan ke logical workspace seperti terlihat pada gambar dibawah ini:

– Ambil 3 buah Switch dari select device box pada bagian Switches lalu tempatkan ke logical workspace seperti terlihat pada gambar dibawah ini:

– Hubungkan 3 PC tadi dengan kabel yang sesuai (kabel Straight) ke masing-masing Switch dengan Ketentuan sebagai berikut :
PC1 FastEthernet -> Switch2 FastEthernet0/11
PC2 FastEthernet -> Switch2 FastEthernet0/18
PC3 FastEthernet -> Switch2 FastEthernet0/6

– Hubungkan masing-masing Switch dengan kabel yang sesuai (kabel Cross) dengan ketentuan sebagai berikut :
Switch2 FastEthernet0/1 -> Switch3 FastEthernet0/3
Switch2 FastEthernet0/2 -> Switch3 FastEthernet0/4
Switch1 FastEthernet0/1 -> Switch3 FastEthernet0/1
Switch1 FastEthernet0/2 -> Switch3 FastEthernet0/2
Switch1 FastEthernet0/3 -> Switch2 FastEthernet0/3
Switch1 FastEthernet0/4 -> Switch2 FastEthernet0/4

– Matikan semua ports dengan menggunakan perintah shutdown pada switch1, switch2, dan switch3. Caranya klik Switch – CLI – ketikan syntax dibawah ini :
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface range fa0/1-24
Switch(config-if-range)#shutdown
Switch(config-if-range)#interface range gi0/1-2
Switch(config-if-range)#shutdown
Switch(config-if-range)#end

– Konfigurasi Switch (switch1, switch2, dan switch3). Caranya klik Switch – CLI – ketikan syntax dibawah ini :
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S1
S1(config)#enable secret class
S1(config)#no ip domain-lookup
S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#line vty 0 15
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#end
%SYS-5-CONFIG_I: Configured from console by console
S1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration…
[OK]
– Konfigurasi PC1, PC2, dan PC3. Caranya klik PC yang ada di logical workspace, lalu set alamat IP tiap-tiap PC dengan ketentuan sebagai berikut:

– Konfigurasi VTP pada semua switch dengan ketentuan sebagai berikut:

Tulis perintah dengan cara klik Switch – CLI – ketikan syntax dibawah ini :

S1(config)#vtp mode server
Device mode already VTP SERVER.
S1(config)#vtp domain Lab5
Changing VTP domain name from NULL to Lab5
S1(config)#vtp password cisco
Setting device VLAN database password to cisco
S1(config)#end

S2(config)#vtp mode client
Setting device to VTP CLIENT mode
S2(config)#vtp domain Lab5
Changing VTP domain name from NULL to Lab5
S2(config)#vtp password cisco
Setting device VLAN database password to cisco
S2(config)#end

S3(config)#vtp mode client
Setting device to VTP CLIENT mode
S3(config)#vtp domain Lab5
Changing VTP domain name from NULL to Lab5
S3(config)#vtp password cisco
Setting device VLAN database password to cisco
S3(config)#end

– Konfigurasi Trunk dan Native VLAN pada semua Switch. Caranya klik Switch – CLI – lalu ketikan syntax dibawah ini :
S1(config)#interface range fa0/1-4
S1(config-if-range)#switchport mode trunk
S1(config-if-range)#switchport trunk native vlan 99
S1(config-if-range)#no shutdown
S1(config-if-range)#end

S2(config)# interface range fa0/1-4
S2(config-if-range)#switchport mode trunk
S2(config-if-range)#switchport trunk native vlan 99
S2(config-if-range)#no shutdown
S2(config-if-range)#end

S3(config)# interface range fa0/1-4
S3(config-if-range)#switchport mode trunk
S3(config-if-range)#switchport trunk native vlan 99
S3(config-if-range)#no shutdown
S3(config-if-range)#end

– Konfigurasi VLAN melalui VTP Server (Switch1). Caranya klik Switch – CLI – lalu ketikan syntax dibawah ini :
S1(config)#vlan 99
S1(config-vlan)#name management
S1(config-vlan)#exit
S1(config)#vlan 10
S1(config-vlan)#name faculty-staff
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#name students
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#name guest
S1(config-vlan)#exit

– Konfigurasi IP address pada ketiga Switch). Caranya klik Switch – CLI – lalu ketikan syntax dibawah ini :
S1(config)#interface vlan99
S1(config-if)#ip address 172.17.99.11 255.255.255.0
S1(config-if)#no shutdown
S2(config)#interface vlan99
S2(config-if)#ip address 172.17.99.12 255.255.255.0
S2(config-if)#no shutdown
S3(config)#interface vlan99
S3(config-if)#ip address 172.17.99.13 255.255.255.0
S3(config-if)#no shutdown

– Konfigurasi port switch untuk VLAN pada setiap PC di Switch 2. Caranya klik Switch – CLI – ketikan syntax dibawah ini :
S2(config)#interface range fa0/5-10
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 30
S2(config-if-range)#interface range fa0/11-17
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 10
S2(config-if-range)#interface range fa0/18-24
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 20
S2(config-if-range)#end
S2#copy running-config startup-config
Destination filename [startup-config]? [enter]
Building configuration…
[OK]

– Re-enable port pada Switch2.Caranya klik Switch – CLI – ketikan syntax dibawah ini :
S2(config)#interface range fa0/6, fa0/11, fa0/18
S2(config-if-range)#no shutdown

Atur Priority pada semua Vlan di Switch1 ke 4096.Caranya klik Switch – CLI – ketikan syntax dibawah ini:
S1(config)#spanning-tree vlan 1 priority 4096
S1(config)#spanning-tree vlan 10 priority 4096
S1(config)#spanning-tree vlan 20 priority 4096
S1(config)#spanning-tree vlan 30 priority 4096
S1(config)#exit

– Ubah konfigurasi IP PC3 menjadi 172.17.99.23 255.255.255.0 dan atur port Fa0/6 ke VLAN 99. Caranya klik Switch – CLI – ketikan syntax dibawah ini :

S2(config)# interface fa0/6
S2(config-if)#switchport access vlan 99

– Lakukan ping dari Switch 2 ke PC jika ping success 100 percent maka langkah ini telah berhasil.

– Konfigurasi PVST Rapid Spanning Tree Protocol menggunakan perintah di bawah ini dan lakukan pada semua switch. Caranya klik Switch – CLI – ketikan syntax dibawah ini:

S1(config)#spanning-tree mode rapid-pvst
S2(config)#spanning-tree mode rapid-pvst
S3(config)#spanning-tree mode rapid-pvst

Hasil
Untuk membuktikan apakah konfigurasi-konfigurasi diatas yang kita lakukan itu berhasil atau tidak, yaitu dengan cara melakukan ping dari PC3 ke Switch1. Jika ping telah berhasil lalu matikan port fa0/1 dan fa0/3, ping akan tetap berjalan walaupun port tersebut telah dimatikan.

RTO tidak muncul walaupun kabel putus pada jalur paket data. Inilah yang membedakan antara STP dan RSTP.

Perancanggan dan Konfigurasi Spanning tree Protocol

Laporan VII

Oleh: Sulaiman (11615011)

A. Tujuan Pembelajaran

•Menghapus konfigurasi startup dan reload konfigurasi default, pengaturan switch ke default negara

•Melakukan tugas-tugas konfigurasi dasar pada switch

• Mengamati dan menjelaskan perilaku default Spanning Tree Protocol (STP, 802.1D)

•Amati respon terhadap perubahan dalam topologi spanning tree

B. Dasar teori

Spanning Tree Protocol (disingkat STP) adalah protokol jaringan yang menjamin topologi jaringan bebas-pengulangan untuk penghubung EthernetLAN. Fungsi dasar dari STP adalah untuk mencegah pengulangan penghubung dan radiasi siaran yang dihasilkan dari mereka. Pohon rentang juga memungkinkan desain jaringan untuk memasukkan cadang tautan (redundan) untuk menyediakan jalur cadangan otomatis jika tautan aktif gagal, tanpa bahaya dari perulangan yang tidak diinginkan dalam jaringan, atau kebutuhan untuk panduan mengaktifkan / menonaktifkan cadangan tautan ini.

Spanning Tree Protocol (STP) distandarisasi sebagai IEEE 802.1D. Seperti namanya, protokol ini bisa menciptakan pohon rentang dalam jaringan bertautan dari lapisan 2 layer penghubung (biasanya switch ethernet), dan menonaktifkan tautan tersebut yang bukan bagian dari pohon rentang, meninggalkan jalur aktif tunggal antara dua node jaringan.

STP ini berdasarkan algoritma yang ditemukan oleh Radia Perlman ketika bekerja untuk Digital Equipment Corporation

C.  Perancanggan dan Konfigurasi Spanning tree Protocol

Tugas 1: Lakukan Konfigurasi Beralih Dasar

Langkah 1: Kabel jaringan yang mirip dengan yang di diagram topologi.

Anda dapat menggunakan saklar saat ini di lab Anda selama ia memiliki antarmuka yang diperlukan ditunjukkan pada topologi

diagram. Output ditunjukkan pada laboratorium ini didasarkan pada Cisco 2960 switch. Model switch lainnya mungkin

menghasilkan output yang berbeda.

Menyetel koneksi konsol untuk ketiga switch.

Langkah 2: Hapus semua konfigurasi yang ada pada switch.

NVRAM jelas, menghapus file vlan.dat, dan kembali switch. Lihat Lab 2.5.1 untuk prosedur ini. Setelah

reload selesai, gunakan show vlan istimewa perintah EXEC untuk mengkonfirmasi bahwa VLAN default hanya

ada dan bahwa semua port ditugaskan untuk VLAN 1.

S1 # show vlan

Langkah 3: Konfigurasi parameter saklar dasar.

Mengkonfigurasi switch S1, S2, dan S3 sesuai dengan pedoman berikut:

•Konfigurasi saklar nama host.

•Disable DNS lookup.

•Mengkonfigurasi sandi EXEC mode kelas.

•Mengkonfigurasi password cisco untuk koneksi konsol.

•Mengkonfigurasi password cisco untuk koneksi vty.

(Output untuk S1 ditampilkan)

Switch>enable

Switch#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#hostname S1

S1(config)#enable secret class

S1(config)#no ip domain-lookup

S1(config)#line console 0

S1(config-line)#password cisco

S1(config-line)#login

S1(config-line)#line vty 0 15

S1(config-line)#password cisco

S1(config-line)#login

S1(config-line)#end

%SYS-5-CONFIG_I: Configured from console by console

S1#copy running-config startup-config

Destination filename [startup-config]?

Building configuration…

[OK]

Tugas 2: Siapkan Jaringan

Langkah 1: Nonaktifkan semua port dengan menggunakan perintah shutdown.

Pastikan bahwa negara saklar awal pelabuhan tidak aktif dengan perintah shutdown.

S1(config)#interface range fa0/1-24

S1(config-if-range)#shutdown

S1(config-if-range)#interface range gi0/1-2

S1(config-if-range)#shutdown

S2(config)#interface range fa0/1-24

S2(config-if-range)#shutdown

S2(config-if-range)#interface range gi0/1-2

S2(config-if-range)#shutdown

S3(config)#interface range fa0/1-24

S3(config-if-range)#shutdown

S3(config-if-range)#interface range gi0/1-2

S3(config-if-range)#shutdown

Langkah 2: Re-enable port pengguna pada S1 dan S2 dalam mode akses.

Lihat diagram topologi untuk menentukan port pada saklar S2 diaktifkan untuk pengguna akhir perangkat

akses. Ketiga port akan dikonfigurasi untuk mode akses dan diaktifkan dengan tidak ada penutupan

perintah.

S1(config)#interface fa0/3

S1(config-if)#switchport mode access

S1(config-if)#no shutdown

S2(config)#interface range fa0/6, fa0/11, fa0/18

S2(config-if-range)#switchport mode access

S2(config-if-range)#no shutdown

Langkah 3: Aktifkan port trunk pada S1, S2, dan S3

Hanya VLAN tunggal yang digunakan di laboratorium ini. Namun trunking telah diaktifkan pada semua link

antara switch untuk memungkinkan VLAN tambahan yang akan ditambahkan di masa depan.

S1(config-if-range)#interface range fa0/1, fa0/2

S1(config-if-range)#switchport mode trunk

S1(config-if-range)#no shutdown

S2(config-if-range)#interface range fa0/1, fa0/2

S2(config-if-range)#switchport mode trunk

S2(config-if-range)#no shutdown

S3(config-if-range)#interface range fa0/1, fa0/2

S3(config-if-range)#switchport mode trunk

S3(config-if-range)#no shutdown

Step 4: Configure the management interface address on all three switches.

S1(config)#interface vlan1

S1(config-if)#ip address 172.17.10.1 255.255.255.0

S1(config-if)#no shutdown

S2(config)#interface vlan1

S2(config-if)#ip address 172.17.10.2 255.255.255.0

S2(config-if)#no shutdown

S3(config)#interface vlan1

S3(config-if)#ip address 172.17.10.3 255.255.255.0

S3(config-if)#no shutdown

Pastikan bahwa switch dikonfigurasi dengan benar dengan melakukan ping antara mereka. Dari S1, ping

manajemen antarmuka pada S2 dan S3. Dari S2, ping antarmuka manajemen pada S3.

Tugas 3: Konfigurasi PC host

Mengkonfigurasi interface Ethernet dari PC1, PC2, PC3, PC4 dan dengan alamat IP, subnet mask, dan

gerbang ditunjukkan dalam tabel menangani pada awal laboratorium.

Tugas 4: Konfigurasi Spanning Tree

Langkah 1: Periksa konfigurasi default 802.1D STP.

Pada setiap switch, menampilkan tabel spanning tree dengan acara spanning-tree perintah. Akar seleksi

bervariasi tergantung pada BID dari setiap switch di lab sehingga menghasilkan output yang bervariasi.

Langkah 2: Memeriksa output.

Identifier jembatan (jembatan ID), disimpan di pohon BPDU mencakup terdiri dari prioritas jembatan, ID sistem

ekstensi, dan alamat MAC. Kombinasi atau penambahan prioritas jembatan dan ID sistem

ekstensi dikenal sebagai prioritas ID jembatan. Perpanjangan ID sistem selalu jumlah VLAN.

Sebagai contoh, ID sistem penyuluhan untuk VLAN 100 adalah 100. Menggunakan jembatan standar nilai prioritas 32768, yang

jembatan ID prioritas untuk VLAN 100 sisanya adalah 32868 (32768 + 100).

Acara spanning-tree perintah menampilkan nilai prioritas ID jembatan. Catatan: “prioritas” nilai

dalam kurung merupakan nilai jembatan prioritas, yang diikuti dengan nilai ID sistem

ekstensi.

Tugas 5: Perhatikan respon terhadap perubahan topologi di 802.1D STP

Sekarang mari kita amati apa yang terjadi ketika kita sengaja mensimulasikan link yang rusak

Langkah 1: Tempatkan switch dalam rentang modus pohon debug debug menggunakan perintah rentang-

pohon kejadian

S1#debug spanning-tree events

Spanning Tree event debugging is on

S2#debug spanning-tree events

Spanning Tree event debugging is on

S3#debug spanning-tree events

Spanning Tree event debugging is on

Langkah 2: Sengaja penutupan pelabuhan Fa0 / 1 pada S1

S1 (config) # interface Fa0 / 1

S1 (config-if) # shutdown

Konfigurasi dan Topologi Diagram VTP

Laporan VI

 

Oleh:Sulaiman (11615011)

Tujuan Pembelajaran

• Selidiki konfigurasi saat ini

• Konfigurasi S1 sebagai server VTP

• Konfigurasi S2 dan S3 sebagai klien VTP

• Konfigurasi VLAN di S1

• Konfigurasi trunk pada S1, S2, dan S3

• Memverifikasi status VTP pada S1, S2, dan S3

• Menetapkan port pada VLAN untuk S2 dan S3

• Verifikasi implementasi VLAN dan konektivitas uji

Pengenalan

Dalam kegiatan ini, Anda akan berlatih konfigurasi VTP. Ketika Packet Tracer pertama akan terbuka, akan aktif sudah

berisi konfigurasi parsial. Password user EXEC adalah cisco dan password priveledge EXEC.

Tugas 1: Menyelidiki Konfigurasi Saat Ini

Langkah 1. Pastikan konfigurasi yang sedang berjalan di switch.

Konfigurasi apa yang sudah ada di switch?

Langkah 2. Menampilkan VLAN saat ini pada setiap switch.

Apakah ada sekarang VLAN? Apakah pengguna VLAN VLAN dibuat atau VLAN default?

S1 # pertunjukan singkat vlan

Status Nama VLAN Port

————————————————– —————-

1 aktif standar Fa0 / 1, Fa0 / 2, Fa0 / 3, Fa0 / 4

Fa0 / 5, Fa0 / 6, Fa0 / 7, Fa0 / 8

Fa0 / 9, Fa0/10, Fa0/11, Fa0/12

Fa0/13, Fa0/14, Fa0/15, Fa0/16

Fa0/17, Fa0/18, Fa0/19, Fa0/20

Fa0/21, Fa0/22, Fa0/23, Fa0/24

Gig1 / 1, Gig1 / 2

1002 FDDI-default aktif

1003 token-ring-default active

1004 fddinet-default aktif

1005 trnet-default aktif

Penyelesaian harus sebesar 0% pada akhir Tugas ini.

Tugas 2: Konfigurasi S1 sebagai VTP Server

Langkah 1. Mengkonfigurasi modus perintah VTP.

S1 akan menjadi server untuk VTP. Set S1 ke modus server.

S1 (config) # vtp mode server

Perangkat sudah VTP modus SERVER.

S1 (config) #

Perhatikan bahwa saklar sudah diatur ke modus server secara default. Namun, penting bahwa Anda secara eksplisit

mengkonfigurasi perintah ini untuk memastikan switch berada dalam mode server.

Langkah 2. Konfigurasi nama domain VTP.

Konfigurasi S1 dengan CCNA sebagai nama domain VTP. Ingat bahwa nama domain VTP adalah case

sensitif.

S1 (config) # vtp domain CCNA

Mengubah nama domain VTP dari NULL untuk CCNA

S1 (config) #

Langkah 3. Konfigurasi password domain VTP.

Konfigurasi S1 dengan cisco sebagai password domain VTP. Ingat bahwa password VTP domain adalah case

sensitif.

S1 (config) # vtp sandi cisco

Mengatur perangkat password database VLAN untuk cisco

S1 (config) #

Langkah 4. Konfirmasikan perubahan konfigurasi.

Gunakan perintah show vtp status di S1 mengkonfirmasi bahwa modus VTP dan domain dikonfigurasi

benar.

S1 # menampilkan status vtp

VTP Versi: 2

Konfigurasi Revisi: 0

Maksimum VLAN yang didukung secara lokal: 64

Jumlah VLAN yang ada: 5

VTP Operating Mode: Server

VTP Domain Name: CCNA

VTP Pruning Mode: Dinonaktifkan

VTP V2 Mode: Dinonaktifkan

VTP Perangkap Generasi: Cacat

MD5 digest: 0x8C 0x29 0x40 0xDD 0x7F 0x63 0x7A

Konfigurasi terakhir dimodifikasi oleh 0.0.0.0 pada 0-0-00 00:00:00

Untuk memverifikasi password VTP, gunakan perintah show vtp password.

S1 # show vtp kata sandi

VTP Password: cisco

S1 #

Langkah 5. Periksa hasil.

Persentase penyelesaian Anda harus 8%. Jika tidak, klik Periksa Hasil untuk melihat mana yang diperlukan

komponen belum selesai.

Tugas 3: Konfigurasi S2 dan S3 sebagai Klien VTP

Langkah 1. Mengkonfigurasi modus perintah VTP.

S2 dan S3 akan menjadi klien VTP. Set kedua switch ke mode klien.

Langkah 2. Konfigurasi nama domain VTP.

Sebelum S2 dan S3 akan menerima iklan VTP dari S1, mereka harus milik domain VTP yang sama.

Konfigurasi S2 dan S3 dengan CCNA sebagai nama domain VTP. Ingat bahwa nama domain VTP adalah case

sensitif.

Langkah 3. Konfigurasi password domain VTP.

S2 dan S3 juga harus menggunakan password yang sama sebelum mereka dapat menerima iklan dari VTP VTP yang

server. Konfigurasi S2 dan S3 dengan cisco sebagai password domain VTP. Ingat bahwa VTP domain

password bersifat case sensitif.

Langkah 4. Konfirmasikan perubahan konfigurasi.

Gunakan perintah show vtp status pada setiap switch untuk mengkonfirmasi bahwa modus VTP dan domain adalah

dikonfigurasi dengan benar. Output untuk S3 yang ditampilkan di sini.

S3 # menampilkan status vtp

VTP Versi: 2

Konfigurasi Revisi: 0

Maksimum VLAN yang didukung secara lokal: 64

Jumlah VLAN yang ada: 5

VTP Operating Mode: Klien

VTP Domain Name: CCNA

VTP Pruning Mode: Dinonaktifkan

VTP V2 Mode: Dinonaktifkan

VTP Perangkap Generasi: Cacat

MD5 digest: 0x8C 0x29 0x40 0xDD 0x7F 0x63 0x7A

Konfigurasi terakhir dimodifikasi oleh 0.0.0.0 pada 0-0-00 00:00:00

Perhatikan bahwa angka revisi konfigurasi 0 pada ketiga switch. Mengapa?

Untuk memverifikasi password VTP, gunakan perintah show vtp password.

S3 # show vtp kata sandi

VTP Password: cisco

S3 #

Langkah 5. Periksa hasil.

Persentase penyelesaian Anda harus 31%. Jika tidak, klik Periksa Hasil untuk melihat mana yang diperlukan

komponen belum selesai.

Tugas 4: Konfigurasi VLAN di S1

VLAN dapat dibuat pada server VTP dan didistribusikan ke switch lain dalam domain VTP. Dalam

tugas Anda akan menciptakan 4 VLAN baru pada server VTP, S1. VLAN ini akan didistribusikan ke S2 dan S3

melalui VTP.

Langkah 1. Buat VLAN.

Untuk tujuan penilaian di Packet Tracer, nama-nama VLAN adalah case-sensitive.

• VLAN 10 bernama Fakultas / Staf

• VLAN 20 Siswa bernama

• VLAN Pengunjung 30 bernama (Default)

• VLAN Manajemen 99 bernama asli &

 

Langkah 2. Verifikasi VLAN.

Gunakan perintah show vlan singkat untuk memverifikasi VLAN dan nama mereka.

S1 # pertunjukan singkat vlan

Status Nama VLAN Port

————————————————– ——————

1 aktif standar Fa0 / 1, Fa0 / 2, Fa0 / 3, Fa0 / 4

Fa0 / 5, Fa0 / 6, Fa0 / 7, Fa0 / 8

Fa0 / 9, Fa0/10, Fa0/11, Fa0/12

Fa0/13, Fa0/14, Fa0/15, Fa0/16

Fa0/17, Fa0/18, Fa0/19, Fa0/20

Fa0/21, Fa0/22, Fa0/23, Fa0/24

Gig1 / 1, Gig1 / 2

10 Fakultas / Staf aktif

20 Siswa aktif

30 Pengunjung (Default) aktif

99 Manajemen & asli aktif

1002 FDDI-default aktif

1003 token-ring-default active

1004 fddinet-default aktif

1005 trnet-default aktif

Jika Anda memasukkan perintah yang sama pada S2 dan S3, Anda akan melihat bahwa VLAN tidak berada dalam VLAN mereka

database? Mengapa tidak?

Langkah 4. Periksa hasil.

Persentase penyelesaian Anda harus 46%. Jika tidak, klik Periksa Hasil untuk melihat mana yang diperlukan

komponen belum selesai.

 

Tugas 5: Konfigurasi Batang pada S1, S2, dan S3

Gunakan perintah switchport mode trunk untuk mengatur mode trunk untuk setiap trunk link. Gunakan

switchport trunk native vlan 99 perintah untuk mengatur VLAN 99 sebagai VLAN asli.

Langkah 1. Konfigurasi FastEthernet 0/1 dan FastEthernet 0/3 pada S1 untuk trunking.

Masukkan perintah yang sesuai untuk mengkonfigurasi dan mengatur trunking VLAN 99 sebagai VLAN asli.

Setelah dikonfigurasi, Trunking Protocol Dynamic (DTP) akan memunculkan link trunk. Anda dapat memverifikasi S2 dan S3

sekarang trunking dengan memasukkan antarmuka perintah show Fa0 / 1 switchport pada S2 dan pertunjukan

antarmuka Fa0 / 3 switchport perintah pada S3.

Jika Anda menunggu beberapa menit untuk Packet Tracer untuk mensimulasikan semua proses, S1 akan mengiklankan VLAN

konfigurasi untuk S2 dan S3. Hal ini dapat diverifikasi pada S2 atau S3 dengan kedua perintah vlan acara singkat dan

tersebut vtp menunjukkan status perintah.

Namun, adalah praktik terbaik untuk mengkonfigurasi kedua sisi link trunk ke modus pada.

Langkah 2. Konfigurasi Fast Ethernet 0/1 pada S2 untuk trunking.

Masukkan perintah yang sesuai untuk mengkonfigurasi dan mengatur trunking VLAN 99 sebagai VLAN asli.

Langkah 3. Konfigurasi Fast Ethernet 0/3 di S3 untuk trunking.

Masukkan perintah yang sesuai untuk mengkonfigurasi dan mengatur trunking VLAN 99 sebagai VLAN asli.

Langkah 5. Periksa hasil.

Persentase penyelesaian Anda harus 77%. Jika tidak, klik Periksa Hasil untuk melihat mana yang diperlukan

komponen belum selesai.

Tugas 6: Verifikasi Status VTP

Menggunakan status pertunjukan vtp dan vlan menunjukkan perintah singkat, pastikan berikut ini.

• S1 harus menunjukkan status server

• S2 dan S3 harus menampilkan status klien

• S2 dan S3 harus memiliki VLAN dari S1

Catatan: iklan VTP dibanjiri seluruh manajemen domain setiap lima menit atau

setiap kali perubahan terjadi dalam konfigurasi VLAN. Untuk mempercepat proses ini, Anda dapat beralih di antara Realtime dan mode Simulasi sampai babak berikutnya pembaruan. Namun, Anda mungkin harus melakukan ini

beberapa kali karena ini hanya akan meneruskan jam Packet Tracer sebesar 10 detik setiap kali. Atau,

Anda dapat mengubah salah satu dari switch klien ke mode transparan dan kemudian kembali ke modus klien.

Berapa jumlah revisi konfigurasi? ___________

Mengapa nomor revisi konfigurasi yang lebih tinggi dari jumlah VLAN Anda buat?

Apakah saat ini jumlah VLAN yang ada? ___________

Mengapa ada VLAN lebih ada daripada empat yang Anda buat?

Penyelesaian tetap harus pada 77% pada akhir Tugas ini.

Tugas 7: VLAN Assign untuk Pelabuhan

Gunakan perintah switchport mode akses untuk mengatur mode akses untuk link akses. Gunakan

switchport mengakses vlan vlan-id perintah untuk menetapkan VLAN ke port akses.

Langkah 1. Menetapkan port pada VLAN untuk S2.

• Fa0/11 pada VLAN 10

• Fa0/18 pada VLAN 20

• Fa0 / 6 pada VLAN 30

Langkah 2. Menetapkan port pada VLAN untuk S3.

• Fa0/11 pada VLAN 10

• Fa0/18 pada VLAN 20

• Fa0 / 6 pada VLAN 30

Langkah 4. Periksa hasil.

Persentase penyelesaian Anda harus 100%. Jika tidak, klik Periksa Hasil untuk melihat mana yang diperlukan

komponen belum selesai.

Tugas 8: Verifikasi Implementasi VLAN dan Konektivitas Uji

Langkah 1. Verifikasi konfigurasi VLAN dan tugas pelabuhan.

Gunakan perintah show vlan singkat untuk memverifikasi konfigurasi VLAN dan tugas port pada setiap switch.

Bandingkan output Anda untuk topologi.

Langkah 2. Uji konektivitas antara PC.

Ping antara PC pada VLAN yang sama harus berhasil, ping sementara antara PC pada VLAN yang berbeda

harus gagal.

Dari PC1 ping PC4.

Dari PC2 ping PC5.

Dari PC3 ping PC6.